System Status

Service Disruption
Incident Report for LEAP
Resolved
Some users may have experienced difficulty logging into LEAP. We have identified the issue and it is now resolved.
Posted Nov 16, 2022 - 00:08 UTC
Investigating
Some users may be experiencing intermittent errors while using LEAP. We are working urgently to resolve these issues. We will provide an updated status when we have identified the issue.
Posted Nov 16, 2022 - 00:08 UTC
This incident affected: LEAP United States (LEAP Matter & Document Services, LEAP Accounting Services, LEAP Mobile, LEAP 365).