System Status

Login Issues
Incident Report for LEAP
Resolved
Some users may have experienced intermittent errors while using LEAP. We have identified the issue and it is now resolved.
Posted Sep 23, 2020 - 09:10 AEST
Update
Some users may experience disruption while using LEAP due to issues currently affecting some services. We are monitoring the situation and will provide an updated status when we have identified the issue.
Posted Sep 21, 2020 - 16:28 AEST
Investigating
Some users may be experiencing difficulty logging into LEAP since 9AM AEST. We are working urgently to resolve these issues.
We will provide an updated status when we have identified the issue.
Posted Sep 21, 2020 - 10:05 AEST
This incident affected: LEAP Australia & New Zealand (LEAP Matter & Document Services, LEAP Accounting Services, LEAP Mobile).