Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 18, 2023 - 08:00 AEST
Scheduled
LEAP Servers will be undergoing maintenance Sunday, September 17th. LEAP will be operating in offline mode between 18:00 and 02:00 EDT. Thank you for your understanding while we undertake this work.
Posted Sep 14, 2023 - 13:49 AEST
This scheduled maintenance affected: LEAP United States (LEAP Matter & Document Services, LEAP Accounting Services, LEAP Mobile, LEAP 365, LEAP API Gateway).