System Status

Login Issues
Incident Report for LEAP
Resolved
Some users may have experienced difficulty logging into LEAP. We have identified the issue and it is now resolved.
Posted Aug 05, 2022 - 09:52 EDT
Investigating
Some users may be experiencing difficulty logging into LEAP. We are working urgently to resolve these issues.
We will provide an updated status when we have identified the issue.
Posted Aug 05, 2022 - 09:15 EDT
This incident affected: LEAP Australia & New Zealand (LEAP Matter & Document Services, LEAP Accounting Services, LEAP Mobile).